Archive: ‘SharePoint’ Category

Really…Free SharePoint 2010 Site Anyone?? =o)

5 comments January 28th, 2011

In my last post, I discussed signing up for a free SharePoint 2010 site.  It was a good idea to get people to know more about SharePoint by just giving away a site to play with.  Well, I wasn’t ready to do it apparently, I was going to have to create the site, create credentials, give them access, e-mail it to people, and maybe the list goes on from there as well.

Well NOT anymore! =o) I integrated a SP2010 Web Application and Site Collection with Windows Live, so if you have a Windows Live Account, or even if you don’t, its free, and you can have one in about 2 minutes: Signup for Windows Live Account Now!

If you have one or now that you do have one…just go to WWW2SHAREPOINTADVICEdotNET, look under Announcements, follow the directions (2 more minutes) and you now have a SharePoint 2010 site, blog, wiki, or whatever you want that SharePoint 2010 has to offer…it’s a lot. =o) So in, 4 minutes, you have a SharePoint 2010 site you are in full control of, and you don’t even have to talk to me!  You can still say Hi though! =o/ HaHa…

Free SharePoint 2010 Site Anyone?

2 comments January 25th, 2011

There is a lot of interest in SharePoint 2010, it would be great to have a site to just play around with right? I believe I was just having this discussion during lunch yesterday of how sometimes FREE just isn’t good enough, and I totally agree.  When there is something you need to be able to do, sometimes you get what you pay for, and if you paid nothing, well there you go.  On that note, I am offering a free SharePoint 2010 site to anyone who would like to use it for whatever free is good enough for.  If you’re interested in having one, just click here, fill out the form, and I will set it up for you.

SharePoint Performance Counters Missing

No comments January 19th, 2011

I had a client issue today that I’d never run across before. Their SharePoint Performance Counters were missing from PerfMon, and thier workflows weren’t running. The WorkFlow issue oddly enough makes sense although you wouldn’t think so from first glance. The OWSTimer service for SharePoint uses these performance counters, if they’re missing, you may not notice it from trying to run PerMon, but you’ll definitely notice when your workflows no longer execute. You’ll also start to see errors such as this one in the event view and ULS logs:  

w3wp.exe (0x1674) 0x07CC Windows SharePoint Services Workflow Infrastructure 72fq Unexpected Start Workflow: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly. at System.Diagnostics.PerformanceCounter.Initialize() at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, String instanceName, Boolean readOnly) at System.Workflow.Runtime.PerformanceCounterManager.CreateCounters(String name) at System.Workflow.Runtime.Hosting.DefaultWorkflowSchedulerService.OnStarted() at System.Workflow.Runtime.Hosting.WorkflowRuntimeService.HandleStarted(Object source, WorkflowRuntimeEventArgs e) at System.EventHandler`1.Invoke(Object sender, TEventArgs e)

Continue reading…

SharePoint 2010 Prerequisite Install

2 comments January 9th, 2011

There has been several times now that I’ve had the need to install SharePoint 2010 where there was no available internet connection.  The internet is everywhere right??  Well, not really.  There are testing environments, classified networks, and probably more that I can’t think of right now that are unable toconnect.  Installing SharePoint 2010 becomes pretty impossible if you don’t already have the necessary files handy.  Even if you do, you’ve got to install them one by one, who does that anymore right?  I put together an .ISO file with all the necessary prerequisite files and scripts to install SharePoint without an internet connection, download it here and follow the simple preparation instructions below.

  1. Download the SP2010_PreReq.iso file.
  2. Mount the ISO file to your operating system or burn them to a CD.
  3. Copy the folder named PrerequisiteInstallerFiles to the root of SharePoint 2010 RTM folder or DVD compilation.
  4. Copy the file named PrerequisiteInstaller.Arguments.txt to the root of SharePoint 2010 RTM folder or DVD compilation.
  5. Modify the paths within the file named Prereq_SP2010.cmd to point to the PrerequisiteInstallerFiles folder.
  6. Execute Prereq_SP2010.cmd.
  7. Once the above is completed, you should be able to install SharePoint 2010.

Windows Registry Scripts

No comments January 3rd, 2011

Often we find ourselves looking up the same registry paths and mods over and over again every time we deploy a SharePoint Farm. If we’re lucky we’ll remember to export the registry key after we modify them for use down the road, but of course it either never leaves the server or sits on a media we no longer use. So for my benefit and yours, I figured I’d add the scripts here:

Just copy and paste them into a .reg file and double click, or you can download it (Click the name of the file) from here:

Disable Loopback:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"DisableLoopbackCheck"=dword:00000001

Disable FIPS:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy]
"Enabled"=dword:00000000

Disable UAC:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLUA"=dword:00000000